The Official XenForo Bug Report Thread

Discussion in 'Suggestions & Feedback' started by LazloPsylus, Dec 3, 2015.

  1. Clownacy

    Clownacy Grumpy Staff

    Joined:
    Aug 15, 2014
    Messages:
    849
    Not a bug, per se, but I can't edit a post that contains more than 10000 characters? I just want to fix the formatting on one my threads, now that we have BBcode back.
     
  2. redhotsonic

    redhotsonic Also known as RHS Retired Staff

    Joined:
    Aug 10, 2007
    Messages:
    2,967
    Location:
    England

    Cheers, but I have just discovered it doesn't work when double clicking on the "Showroom" sub-forum.

    EDIT: I meant "Submissions", not "Showroom". Sorry!
     
    Last edited: Dec 7, 2015
  3. Pacca

    Pacca Level 1 inflatable otter thing Member

    Joined:
    Jul 5, 2014
    Messages:
    1,128
    Location:
    The Moon (again)
    I had to click the Showroom monitor like 5 times to break it :|
     
  4. redhotsonic

    redhotsonic Also known as RHS Retired Staff

    Joined:
    Aug 10, 2007
    Messages:
    2,967
    Location:
    England
    I meant the Submission forums, sorry. I can't break that at all.
     
  5. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    Yeah, I don't know what's the Submission forum's deal. You have to enter it and clear the monitors in there for the top-level one to clear. I'll look into it.

    Also, before I forget, I coded up SoundCloud embed support for the media BBCode, in case no one reads the help page (I know I don't). It'll embed just Like YouTube and other stuff. You bastards can thank me later for that pain in the ass.
     
    NeoFusionBox likes this.
  6. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,753
    Location:
    italy
    Right, since you brought up the Embed topic... would it be possible at all to disable Embeds like you can disable signatures, for example? I don't mean to disable them completely, but to render them as plain links. Only if it's not too complicated on your end.
     
  7. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    I'll look into it, but I'm not sure I can do it without basically torching auto-embed. I'll have some spare time to work with now, though, so I'll poke around a bit and see if I can work out something.

    ~E~: Altered settings to spit out link and embed. Might not quite be what you want, and it may cause problems with quoting media, but we can test-run for now. Sorry if I mis-interpreted your request, though.
     
    Last edited: Dec 8, 2015
  8. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,753
    Location:
    italy
    What I meant is, when I read a topic, is it possible to see plain external links to Youtube instead of the embedded Youtube player? For some reasons I've never been a fan of embedded media, I prefer to open them in another tab (maybe at another time). I rarely mentioned this before because I didn't want to bother anyone, but since you're getting your hands dirty, I thought I might as well try. Don't worry if it's too hard or too pointless to do since I'm the only one asking for it. I lived with embedded stuff until today, I can still live with that.
     
  9. Pacca

    Pacca Level 1 inflatable otter thing Member

    Joined:
    Jul 5, 2014
    Messages:
    1,128
    Location:
    The Moon (again)
    I'd appreciate that feature too. Sometimes auto embeds can be a bit much when I'm using an old browser or a slow computer, and I'd also enjoy the option to make them into simple links.
     
  10. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    Oh, THAT's what you mean. Alright, yeah, I was way off. Hmm, that may be notably more difficult to do...
     
  11. redhotsonic

    redhotsonic Also known as RHS Retired Staff

    Joined:
    Aug 10, 2007
    Messages:
    2,967
    Location:
    England
    That's why I always provide a link under my embedded video :)

    You should be able to click the title of the embedded video for it to open YouTube up in a new tab and play (you probably know that already, thought I'd mention).
     
  12. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,753
    Location:
    italy
    RHS I know, but the core point behind this is that I'd prefer if the embed couldn't load at all, and Pacguy was on the spot too. Despite everything, there are circumstances in which you prefer that pages are as lightweight as possible.
     
  13. redhotsonic

    redhotsonic Also known as RHS Retired Staff

    Joined:
    Aug 10, 2007
    Messages:
    2,967
    Location:
    England
    How do I edit the topic title of my own thread? Editing the first post doesn't show options for it anymore?

    EDIT: Nevermind, found it. At the top, go to "Thread Tools" and then click "Edit Thread". I guess this is an option for everyone in their own topics. Or maybe I can see this because I'm staff.
     
  14. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,753
    Location:
    italy
    I can confirm that Pro Users, and probably normal members too at this point, don't have an "edit thread" option in the "thread tools".

    Also, while looking for one of my own topics, I randomly found that I can still delete my posts in one of the secret subforums, for which I won't provide neither a name nor an ID, but since it's the only secret subforum I can read, it won't be hard for you to pinpoint it.

    Interestingly enough, I lost the mod powers over the smps music competition instead. Not that it matters since that competition is dead anyway.
     
  15. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    Heh, I knew there would still be permission issues lurking about to fix. I'll look into it after lunch.

    ~E~: Alright, I *think* I fixed the permissions. I just checked with a test account on a hidden forum set to standard member rules, and the account was able to edit title and everything using thread tools. Also, nineko has his mod power back in the SMPS Competition. If there still seems to be thread name editing issues, please specify the specific forum, as it may be some screwy per-forum permissions that I need to tweak.
     
    Last edited: Dec 11, 2015
  16. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,753
    Location:
    italy
    It looks like I can't start a new conversation, even if I cheat and I type the intended URL by hand.
     
  17. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    A couple of things got muddled in the permissions. Should be fixed now.
     
  18. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,753
    Location:
    italy
    Thanks :)
     
  19. Arsen

    Arsen Active Member In Limbo

    Joined:
    May 16, 2014
    Messages:
    39
    Location:
    Erevan
    [​IMG]
    Hello again. So i am trialist evreryone knows, I know that's not a bug, its just issue with permissions, but you can post thread inside "Site News" topic.
     
  20. Novedicus

    Novedicus Well-Known Member Member

    Joined:
    Aug 26, 2013
    Messages:
    858
    Yeah, the option to make a thread in the Site News subforum is also available to me.
     
    Last edited: Mar 15, 2017