Forums Upgraded to IPB 3.4

Discussion in 'Site News' started by OrdosAlpha, Dec 3, 2012.

Thread Status:
Not open for further replies.
  1. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    As the topic title suggests, the forums have been upgraded from IPB 3.3.4 to IPB 3.4. The forums have also undergone a content rebuild as well, so certain signatures may be bollocked as a result, and so will need to be fixed.
     
    Last edited by a moderator: Dec 3, 2012
  2. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,772
    Location:
    italy
    It seems that the update caused several problems to the URL bbcode, not only in new post, many old posts were also affected o_O


    I'll use rounded brackets in this post to provide my examples.


    It seems that the (url)address(/url) syntax is no longer valid (which forced me to edit my post here, for example), and it has also been stripped from all the existing posts (leading to the second link in this post to end in ".html.", for example), which is a bad thing, I've used that syntax a lot in the past (while I'm aware that links don't need the URL bbcode to work and can simply be written within a post, I don't like to do so because that feature often has problems with special characters, most notably brackets or the dot in the example above, I think the % sign is problematic too which is even worse).


    The (url=address)text(/url) syntax still seems to be valid instead.
     
    Last edited by a moderator: Dec 4, 2012
  3. Dandaman955

    Dandaman955 Well-Known Member Member

    Joined:
    Jan 18, 2010
    Messages:
    859
    Location:
    North Wales
    And the quotes fuse with the posts as well.
     
  4. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    IP re-worked a chunk of the BBCode parsing code and made a few frontend tweaks in IPB 3.4, though not all for the better. As a result, certain aspects of the re-worked code and tweaks ends up being buggered when put into practice and more so with older posts. The quoting code got some major attention, and these changes aren't all that popular. The frontend, namely CKEditor, wasn't even supposed to get any work done on it for 3.4, it was all supposed to be backend only. The truth is, IP want to drop BBCode altogether, and eventually that will happen. In the meantime, I'll try and resolve these issues, though I ain't promising anything.
     
  5. MarkeyJester

    MarkeyJester ! % # @ Member

    Joined:
    Jun 27, 2009
    Messages:
    2,761
    This especially, it's caused myself quite the bit of confusion as well as others, I think they're only fused "design" wise, not necessarily post wise.
     
    Last edited by a moderator: Dec 6, 2012
  6. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,772
    Location:
    italy
    I noticed the quote problem too, but I thought it was a problem with my old Firefox not rendering the page as it should...
     
  7. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    Quote tags are more likely to be mainly a css issue. I'm planning to look into it over the weekend.
     
  8. redhotsonic

    redhotsonic Also known as RHS Retired Staff

    Joined:
    Aug 10, 2007
    Messages:
    2,967
    Location:
    England
    That'll be good. A lot of quotes in recent hot topics are becoming hard to read and acknowledge who's quoting what and when they being to express their views.
     
  9. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    BTW, the hidden skin I'm using doesn't have the quote tag issue.
     
  10. redhotsonic

    redhotsonic Also known as RHS Retired Staff

    Joined:
    Aug 10, 2007
    Messages:
    2,967
    Location:
    England
    That's nice, except it doesn't help in situation like this one for everyone else.


    Unless you're prepared to share this hidden skin with everyone else? =P
     
    Last edited by a moderator: Dec 6, 2012
  11. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    I was planning to if the author updated to be 3.4 compatible. Sadly, this may not be done for a while as he's Syrian. The civil war that's engulfed his country has had an effect on internet connectivity there.

    But, I've just checked both of the visible skins, and it looks like the missing quote box issue is only on the NeoBlu skin, but the WWZ skin has a seriously fucked colour scheme for the quote boxes, it's basically using the default skins settings. So, with the quote boxes visible and correctly coloured on the hidden skin, it pretty much certifies that the issues on the visible skins (the IP default skin probably is uneffected as well) is css related. All I need to do is find the buggered css entry on the visible skins and copy pasta the working entry from the hidden skin, and then tweak them a bit.
     
    Last edited by a moderator: Dec 6, 2012
  12. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    OK, the NeoBlu skin was missing the new quote system css. Copy-pasted the missing code over from the hidden skin. So quote boxes are now visible again. And I corrected the colour scheme of the quote boxes on the WWZ skin.
     
  13. redhotsonic

    redhotsonic Also known as RHS Retired Staff

    Joined:
    Aug 10, 2007
    Messages:
    2,967
    Location:
    England
    Well, it sort of worked. The boxes are back, just not the name of the person you quoted. But thats because we quoted people before your fix. Just quoting you now to see if it works after the fix.

    EDIT: Apparently not.


    Also, is it just me, but when I post things and make a new paragraph, once posted, it's all in one paragraph? I have to edit my posts and make new paragraphs again, then it works.
     
    Last edited by a moderator: Dec 6, 2012
  14. Spanner

    Spanner The Tool Administrator

    Joined:
    Aug 9, 2007
    Messages:
    2,345
    WWZ skin was a test of IPB's theme maker. You can delete it and make your own if you want, but I think everyone has got used to the current, working themes.
     
  15. SpirituInsanum

    SpirituInsanum Well-Known Member Member

    Joined:
    Feb 11, 2010
    Messages:
    642
    About quotes, change the style to "ip board", then back to "neo blu", it fixed it for me.
     
Thread Status:
Not open for further replies.