Upgrade Bug Reports

Discussion in 'Suggestions & Feedback' started by Spanner, May 13, 2015.

  1. Spanner

    Spanner The Tool Administrator

    Joined:
    Aug 9, 2007
    Messages:
    2,334
    Put them in here so we know what we need to be looking at over the next few days.
     
  2. D.A. Garden

    D.A. Garden & Knuckles Retired Staff

    Joined:
    Aug 6, 2009
    Messages:
    499
    Location:
    England
    A few things I have noticed:

    • Signatures have vanished completed. Not too sure if this is a bug, or it's something that is no longer supported.
    • Some of the direct links in the Music Thread (Some Soundcloud links and direct MP3 links) no longer allow the music to be played.
    • Region flags do not load.
    • Although the reputation buttons work for posts, you can no longer click them to see who has up-voted, or down-voted, a post.
    • You also can not see any information regarding your reputation points anymore, such as who left them, and on what topics.
    • Some avatars are cut off or squashed to fit inside the circle they are now in. I presume that this could be fixed with a new theme (that is coming soon), but at the moment, it's an issue.
    That's all for now. If I notice anything else, I'll be sure to let you know.
     
    Last edited by a moderator: May 13, 2015
  3. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    I was already aware of the flag images being broken, and I know the reason why. So, that's an easy fix. Well, it will be once I find out where theme files are now stored on the server. I wasn't paying much attention last night after the upgrade, so I didn't notice that signatures were no longer being displayed. So, I'll look into the sigs, and the reputation stuff later. Though these rep changes may have been implememted by Invision themselves. The avatar thing is, I bloody hope, due to the default theme. Hopefully, the new Clean Cut theme doesn't ahve this issue.
     
    Last edited by a moderator: May 13, 2015
  4. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,759
    Location:
    italy
    Oh wow, everything is unusable as fuck.

    Anyway, to report something reasonable, it's impossible to reply to topics in the "Site News" forum, not sure if it's intentional or not, but it was allowed before, and one of Ordos's latests topics (the one about usernames) actually invites people to reply, so I guess it's worth mentioning.
     
  5. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    I'll shift the display name thread into the Suggestions & Feedback sub-forum. Only Admins and staff can actually post in the Site News forum.
     
  6. amphobius

    amphobius spreader of the pink text Member

    Joined:
    Feb 24, 2008
    Messages:
    971
    Location:
    United Kingdom
    This is less of a bug report and more of a feature request - with the new forum software update, will it be possible to enforce a signature height limit once they return? On the previous software signature sizes were getting out of hand and I actually like this signature-less forum right now for being more legible.
     
  7. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    I think I came across sig restriction options in the ACP, when I was having an almost asleep rummage last night.
     
  8. Selbi

    Selbi Plug in, baby. Retired Staff

    Joined:
    Jul 20, 2008
    Messages:
    2,397
    Location:
    Northern Germany
    There's a new thing introduced with this update that's pretty damn annoying to say the least. Apparently they felt like making the plain view of a post (now called "Source") to use HTML instead of BBCode. Now, this might just be a personal thing, but while I do know how to read HTML, it's by far not as intuitive as the BBCode I've gotten used to over literally a decade. Is there a way to roll back or at least configure which type a certain user prefers?

    Since we're on the topic of plain view, the horizontal wrapping still doesn't seem to work.

    It also appears as though the reply form has been completely replaced by the quick reply form. That's pretty annoying, but not as big of an issue. What is an issue is that you can no longer preview posts (probably because the designers thought the Rich Text Box would suffice, which it definitely doesn't).

    Regarding the Rich Text Box, and I think everybody already noticed this, the default paragraph spacing has been increased to an entire line now. Whether that can be classified as convenience or not is less important. The real problem comes when trying to edit old posts. Just by opening the edit form you mess up everything, because every line break seems to get another one thrown at it as well. Example from this post:

    Before:

    And just by clicking on the edit button without changing ANYTHING:

    I also feel like this fucked up everything that was enclosed by [asm] tags before update, as right now all instances of them have every line to be immediately followed by an empty line (which is especially annoying when trying to copy the code). Example.

    The thing I don't get about these updates is why the designers always feel like throwing away everything that was the norm for decades. Innovation doesn't regression.
     
    Last edited by a moderator: May 13, 2015
  9. redhotsonic

    redhotsonic Also known as RHS Retired Staff

    Joined:
    Aug 10, 2007
    Messages:
    2,967
    Location:
    England
    Well, SSRG no longer works at work so I can't browse it properly at lunch (forced to use IE otherwise old systems we use don't work, and can't install other explorer's as you need admin privileges.  Not really anything you can do about it as IE is outdated anyway but still, blah).

    I agree with Selbi; I dislike this "source" and want my BBCode back, although Ordos did warn that will be going so I was expecting it.

    One important issue, I have access to three sub-forums I don't think I am meant to have access to (Hacking contest and 2 projects).  Now I'm not the one to abuse it, but thought I'd better warn you of this, just in case any other member suddenly has access to places they're not meant to and not let you know about it.



    Unless it's been sorted since you posted, signatures are visible for me, but not formatted (centred or whatever).

    EDIT:  Un-ticking the "Show that the message has been edited" does nothing and still says it is.

    EDIT2: Actually, it says "Staff may still be able to see this" so maybe that's why I can see that my own post has been edited.  Can a member from a member group confirm to me if this post has been edited (like redhotsonic edited this post XX minutes ago)?  Thanks.
     
    Last edited by a moderator: May 13, 2015
  10. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    OK, update on the profile flags. They've completely changed how custom profile fields work. The flags weren't broken the way I thought they were. I'm gonna have to rename all the fucking flag images to use proper names, instead of the two letter shorthand names. Seeing as Invision have done away with the 'key' code flag in drop down boxes. Got to use the fucking 'content' code flag instead. So, that will take a bit of time to fix. Got Scotland working, as you can see from my profile. Just another 248 to go. Awesome!
     
  11. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,759
    Location:
    italy
    No, your post does not appear as having been edited to me.

    Also, no, at least I am not able to see any subforums I'm not meant to. You probably do because you're staff and something slipped over, not a bad thing in my opinion,‌‌ staff should see everything (and yes I'm aware there were hidden subforums I couldn't see even when I was staff, never knew why though).

    Also², don't even get me started on how I hate change and this is terrifying. One thing which would probably help to fix compatibility with older browser is to replace the icon fonts with regular images, something I extremely recommend, given that it's doable at all (I would hope so, since it's a css thing so it should be styleable).
     
  12. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    You'll need to do a browser re-cache to see that the flag in my profile is working again.
     
  13. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,759
    Location:
    italy
    I am sorry, my post was meant to be a direct reply to RHS, I didn't see you posted inbetween.
     
  14. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    Removed the circle overlay crap from avatars. Another thing fixed.
     
  15. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    I'm going to have to go through all the permission masks, and re-do them all. Plus, the handy feature of permission mask overriding has been rmoved. So, it's even more of a headache.
     
    Last edited by a moderator: May 14, 2015
  16. NeoFusionBox

    NeoFusionBox Lost in the armageddon. Member

    Joined:
    Sep 9, 2013
    Messages:
    477
    Location:
    Cyber Factory
    ​Good to know, but maybe it can be a optional thing? perhaps it can be a personal config by a member , if server doesn't limit it or something like that.

    About the bugs, I've noticed  the Chaos Emeralds / Member's Rank image / link doesn't load, only at profile page.

    http://sonicresearch.org/forums/flags/Italy.gif
     
  17. SeanieB

    SeanieB Dude! Administrator

    Joined:
    Jul 19, 2008
    Messages:
    226
    Location:
    San Diego, CA
  18. OrdosAlpha

    OrdosAlpha RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,780
    Location:
    Glasgow, Scotland
    ​Sadly, the avatar overlay has to be either on or off for everybody. There is no opt in or out at a user level option. And from what I can tell, rank images are no longer included in a user's post profile. They're now only on a user's actual profile page. I'll try and get them included in the post profiles again.
     
  19. Pacca

    Pacca Confused floof Member

    Joined:
    Jul 5, 2014
    Messages:
    1,128
    Location:
    The Moon (again)
    The status feed no longer appears in the popup when you hover over someones name, nor does it appear at the top of ones profile. It makes it feel rather pointless when no one can see it without actively looking it up...
     
  20. nineko

    nineko I am the Holy Cat Member

    Joined:
    Mar 24, 2008
    Messages:
    1,759
    Location:
    italy
    [​IMG]

    Please, make it possible to change notification settings, I don't want to receive any emails whatsoever. There are other locked entries below as well (messenger and something else). I tried to disable as much as I could, I even tried to cheat with some black magic, but I couldn't disable some of them.