Upgrade Bug Reports

Discussion in 'Suggestions & Feedback' started by Spanner, May 13, 2015.

  1. Pacguy

    Pacguy Not as active as I used to be... Member

    Joined:
    Jul 5, 2014
    Messages:
    907
    Location:
    SOMEWHERE!!! OVER THE RAINBOW!!!
    The two links underneath the Discussion and Q&A section ("this list of useful links" and "these guidelines") are broken. They seem to be leftover from the old forum software, as they redirect to the front page.
     
  2. オルドスアルファ

    オルドスアルファ RIGHT! Naebody move! Administrator

    Joined:
    Aug 5, 2007
    Messages:
    1,762
    Location:
    Glasgow, Scotland
    I'll do some digging and update those URLs ASAP.
     
  3. CaveQuest

    CaveQuest Creator and moderator for the telephone projects Member

    Joined:
    Jul 18, 2015
    Messages:
    750
    Location:
    Sweden
    So I cannot read pages or set them as read then reload the site or go to the homepage without the thing still being not read over at the Questions and answers thread or that forum overall.
     
  4. redhotsonic

    redhotsonic Also known as RHS Retired Staff

    Joined:
    Aug 10, 2007
    Messages:
    2,947
    Location:
    England
    Seems fine to me. What browser are you using?

    What if you set the whole forum as read (main page, at the top under the logo); does that work?
     
  5. CaveQuest

    CaveQuest Creator and moderator for the telephone projects Member

    Joined:
    Jul 18, 2015
    Messages:
    750
    Location:
    Sweden
    I was using the latest version of Chrome. And it's still there.
     
  6. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    Sounds suspiciously like a caching issue. Cleared cache and cookies? Tried a different browser?
     
  7. CaveQuest

    CaveQuest Creator and moderator for the telephone projects Member

    Joined:
    Jul 18, 2015
    Messages:
    750
    Location:
    Sweden
    Yes. That seems to have fixed it.
     
  8. NoneofyourBusiness

    NoneofyourBusiness Stay fresh~! Member

    Joined:
    Apr 27, 2016
    Messages:
    85
    Location:
    under the Newmaker Plane
    I don't know if this is a bug, per se, but I'm able to report my own account?
     
  9. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    Yeah, not a bug. Looks intentional. Why? I dunno. Ask Xenforo devs.
     
  10. TheStoneBanana

    TheStoneBanana The Bananaman Member

    Joined:
    Nov 27, 2013
    Messages:
    584
    Location:
    The Milky Way Galaxy
    Someone posted a thread today which made me notice that tutorials are able to be posted by anyone in the "Approved" catagory. This doesn't really seem like intended behavior.
     
  11. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    You're right, that is a bug. I've revoked permissions for posting new threads in the two Approved subforums in Submissions for Members and Trialists.
     
  12. Jefftastic

    Jefftastic n00blet Member

    Joined:
    Jul 23, 2017
    Messages:
    45
    Location:
    In Antartica
    So, a lot of links seem to be broken when I click on them.

    Take note these posts were around the 2010-2014 and almost all of them are redirecting to front page, yet the URL is different.
     
  13. Natsumi

    Natsumi Markey's Member

    Joined:
    Oct 7, 2011
    Messages:
    539
    Location:
    Otter's lap
    That's because the links are back from IPB days, they work differently. If you are lucky, you can harvest the topic ID and post ID from them, but I forgot how exactly that works
     
    Misinko likes this.
  14. ProjectFM

    ProjectFM Optimistic and self-dependent Member

    Joined:
    Oct 4, 2014
    Messages:
    640
    Location:
    Portland, Maine
    I believe adding "/community" after ".org" in the links will fix them.

    Edit: I tried it. Even though I swore it worked before, it doesn't work now.
     
    Last edited: Aug 7, 2017
  15. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    Yeah, IPB/IPS links are pretty permanently broken, unfortunately. Different threading structure, so they don't convert. We've tried to convert the important ones as we encounter them (and still can convert on occasion if it's absolutely needed by digging into our old IPS4 DB backup), but generally, they're gone, and it's not feasible to mass-convert.
     
    AkumaYin, Misinko and Natsumi like this.
  16. CHRdutch

    CHRdutch Newcomer Member

    Joined:
    Jun 3, 2017
    Messages:
    17
    Location:
    Earth, I think.
    I'm able to access "the well of shame" by using the search engine. I suppose that that's not meant to happen, or is it?

    That spam though, holy shit.
     
    ProjectFM likes this.
  17. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    It's publicly accessible, so technically, it's working as intended. Not much I can do about it without doing some anti-scraping magic, which if demand is high enough, I could do, but currently don't see a reason to be concerned enough about it to implement a proper method to hide it from scraping.
     
  18. CHRdutch

    CHRdutch Newcomer Member

    Joined:
    Jun 3, 2017
    Messages:
    17
    Location:
    Earth, I think.
    Oh, sorry, my bad. :confused:
    But if it's publicly accessible, why is it hidden away like that? Why not have it on the main page or somewhere as a sub-forum?
     
  19. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    Well, it's one of those things that's there if you know where to look, but it's not something for general consumption. Which is why I'll be making some adjustments to shift it appropriately now that everyone knows about it. It's one of those "open secret" sort of deals.
     
  20. LazloPsylus

    LazloPsylus A Certain Scientific Railgun The Railgun

    Joined:
    Nov 25, 2009
    Messages:
    Location:
    Academy City
    Quick head's up, I know Soundcloud links are not working suddenly. Looking into the issue.

    Update: Looks like Soundcloud's completely changed their embed system, so now I've got to make some weird workaround to make it work. No ETA on fix.

    Update 2: Uh... this one's going to be a mess. Going to basically have to implement an oEmbed. YAY!

    Update 3: Good news: Written some PHP code that handles the oEmbed. Bad news: Having trouble getting it hooked into XF's callbacks. Almost there...

    Update 4: SoundCloud is fixed. You're welcome.
     
    Last edited: Oct 12, 2017
    CaveQuest and redhotsonic like this.